关于Opentrons Python协议API版本1的一切你需要知道的

随着4.0.0软件版本的发布,Opentrons将不再支持Python协议API版本1。以下是你需要知道的。

在我们即将发布的4.0.0软件版本以及未来的版本中,Opentrons将不再支持Python协议API Version 1 (APIv1)。

去年,我们介绍版本2Opentrons Python协议的API (APIv2)ーOT-2核心操作的一个主要更新软件和协议编程接口,提高了可靠性和易用性对于Python API用户,包括:

软件的主要更新,定义了机器人、模块和实验室的几何形状,确保协议命令准确和一致地执行。

——简化OT-2故障诊断,使支持团队能够更准确地诊断和解决问题。

——更新的协议编程接口,使API更容易学习和使用。

自从APIv2发布以来,我们一直在继续开发它,并添加了一些特性和bug修复7新的API小版本,支持新的吸管和模块,改变运动参数和吸管速度

然而,我们不再能够同时支持两个API版本,并且正在迁移我们的系统以支持APIv2。虽然取消一个产品总是很困难,但这样做可以让我们把精力集中在一个强大、可靠的产品体验上。

如果您还没有从APIv1更新到APIv2:

从4.0.0开始,OT-2软件将不再支持使用APIv1构建的协议。您将继续能够使用OT-2的当前软件版本运行APIv1协议。

如何更新协议从APIv1到APIv2:

为了确保在此更新中使用OT-2的最佳体验,我们建议尽快更新APIv1协议。方法如下:

  • 如果你有一个协议,并且自己也愿意编辑它,那就阅读吧这个简短的指南
  • 如果您想从头编写一个新协议,请阅读这个文档
  • 如果您想帮助编写一个新的协议或更新现有的协议,请给我们的应用程序工程团队发电子邮件protocols@www.panhunting.com

如果您还没有计划更新:

虽然Opentrons总是建议使用最新的可用软件版本,但如果你还没有准备好更新,你可以抑制新的OT-2软件和Opentrons应用发布的通知。然而,使用较旧的软件版本意味着它将不再接受bug修复,您使用OT-2可能会遇到问题。
当你准备更新时,导航到Opentrons应用程序中的“更多”标签,它将指导你更新应用程序和机器人软件。

需要额外的帮助吗?请通过support@www.panhunting.com联系我们。